
Portfolio in Flash 5
Prepare the Timeline:

Choose Insert > Layer 4 times to add 4 
layers.  Rename the layers by double clicking 
on their names to actions, logo, buttons, 
background.

Set the Background Colour of the Movie:

Choose Modify > Movie and click on the 
colour chip to set the background colour of 
the movie to a neutral grey.

Create a Flying Logo:

1. Choose Insert > New Symbol. Name it “flying logo”. Click 
on the radio button graphic as the behavior. Click OK.

2. Create some 34 pt. text for your logo with the text tool. 
Choose a font from the Character Panel (Window > Panels 
> Character, Cmd-T) and colour from the Tools palette. 

3. Click on Scene 1 in the upper left hand corner of the 
document window to move from editing the Flying logo 
symbol back to Scene 1 of the movie.

4. Open the Library window with Window > Library
(Cmd-L).  Select the layer named logo, then drag the icon 
for flying logo from the library window onto the movie 
canvas.  The logo layer should now have a black dot 
representing a keyframe.

Tip: To return to editing mode for the flying logo or any 
symbol, double click it’s icon in the library window or double 
click it on the canvas (note the rest of the scene will go 
slightly transparent).

5. Select the logo on the canvas and center it in the middle 
of the canvas with the Align Panel (Window > Panels > 
Align).  Check the To Stage: button on the right of the 
panel, then click the Vertical and Horizontal Align buttons.  
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6. Select the logo and scale it to 10% using the Transform 
panel (Window > Panels > Transform).

7. Set its transparency to 10% using the Effect panel 
(Window > Panels > Effect).  Set pop up to Alpha and then 
type in or slide down to 10%.

8. Select frame 12 of the logo layer and add a keyframe by 
choosing  Insert > Keyframe (F6).

Next, modify the second keyframe so that our animation has 
two different states.

9.  Select frame 12 to select that instance of the logo. Adjust 
it’s transparency using the Effect panel to Alpha of 100%.

10. Scale it to 200% using the Transform panel.  You may 
need to align the logo to the stage again using the Align 
panel.

Play the animation by hitting the return key and you’ll see 
that it is small and very transparent until frame 24 and then 
suddenly it switches to big and opaque.  Next, let’s create 
the in between frames to give us a smooth animation...

11. Click on the first keyframe, frame one, of the logo layer and hold until you see 
a pop up menu appear.  Choose Create Motion Tween.  You can also select the first 
keyframe and then choose Insert > Create Motion Tween.

Play the movie with the return key.  You should see a gradual change in the scale 
and transparency of the logo!  Next let’s make the logo scale down and move to the 
upper left of the canvas.

12. Select frame 18 of the logo layer and add a keyframe,  Insert > Keyframe.

13. With frame 18 selected in the timeline, click on the logo and drag it to a new
position in the upper left hand corner of the canvas.

14. Scale it to 100% using the Transform panel.

15. Select the first keyframe of the two (frame 12) and click and hold until you 
see a pop up menu appear.  Choose Create Motion Tween.  You should now see a 
motion tween arrow in the timeline between frames 12 and 18. Play the movie with 
the return key.

Portfolio in Flash continued
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Add a Background Image that Fades In:

1.  Select the background layer, choose File > Import 
(Cmd-R) and select your background image from your 
project folder in the left hand pane of the window.  Click 
Add, click Import. 

2. Select the image you imported on the canvas.  Scale it by 
clicking on the scale button in the toolbox and then 
resize it with the handles.  Position it over the canvas.

3.  While it’s selected choose Insert > Convert to Symbol. 
Choose Graphic for Behavior. Name it background.

4. Now that it is a symbol, we can set its transparency to 
10% using the Effect panel (Window > Panels > Effect).  
Set pop up to Alpha and the value to 10%.

5. Select frame 18 of the background layer and add a 
keyframe, Insert > Keyframe (F6).

6. Set the transparency of background on frame 18 to 
100% using the Effect panel. View the effect by playing the 
movie with the return key.

Stop the Action:

Save your work, if you haven’t already.  I saved mine to the 
desktop  and named it portfolio.fla  Let’s preview our work 
using Control > Test Movie.  You’ll notice the movie loops 
continuously.  By default Flash will loop or jump to the next 
scene.  To stop the timeline, we’ll add a Stop Action.  Close 
the test movie to return to the project window.

1. Select frame number 18 of the actions layer and choose 
Insert > Keyframe  to add a place for us to add an action.

2. With frame 18 still selected, choose Window > Actions.  
Double click the stop action under the Basic Actions.  You 
should see “stop ();” in the right hand panel.  Notice that 
the frame has a small “a” that shows there is a frame action 
applied. Now test that it works using Control > Test Movie.  
Next let’s add scenes to place our images, resume, 
statement and contact info.

© P.K. Steffen 2001, all rights reserved, www.supercoop.org,  pk@supercoop.org page 3/7

File Import

Actions Panel

Keyframe with 
Stop Action

Convert to Symbol

Scale
Tool

Portfolio in Flash continued



Adding Scenes:

1.  Open the Scene panel (Window > Panels > Scene) and 
double click on the name “Scene 1”.  Rename it intro.  

2. Now add a new scene using Insert > Scene and rename 
it portfolio.

3. Click on the name portfolio to move to that scene.  In the 
portfolio scene add 4 layers using Insert > Layer.  Rename 
the layers by double clicking on their names to actions, 
title, buttons, background.

4. Add a stop action to frame 1 to keep the movie from breezing by this scene.  Select 
frame 1 of the actions layer in portfolio.  Open the Actions panel (Window > Actions) 
and double click on stop.

5. Add some text to let the user know where they are...  
Select the title layer of portfolio, then using the text tool 
create some text that says portfolio.  Place it in the upper 
left hand corner of the canvas.

6. Duplicate the work we have done in the Scene 
portfolio by selecting it and clicking on the duplicate button 
in the lower right hand corner of the scene panel.  Repeat 
two more times.  Rename the new scenes contact, resume 
and statement.

7.  Click on each of the new scenes in the scene panel, and edit the title text we 
created in step 5 above to reflect the scene names.

Next we need to add buttons that will jump the user from the stopped frame to the 
newly created scenes...

Making Buttons:

1. Choose Insert > New Symbol and call the new symbol portfolio button and give 
it a behavior of button.  Click OK.

2.  Add some text to the canvas of the new symbol’s editing window and make it about 
24 points and black.  Change the font using the Character Panel and adjust the color 
via the color well in the Tools palette.

3.  With the text selected, Choose Insert > Keyframe (F6).  Repeat two more times so 
that all four of the button’s states have some text on them (Up, Over, Down and Hit).

Scene Panel

Duplicate 
and Add and Delete

of Scene Panel
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4. Select the Over frame in the timeline.  Change the colour 
of the text to white.

5. Select the Down frame in the timeline.  Choose Modify 
> Transform > Scale and Rotate. Set the scale to 85% 
and 0 degrees.  This creates the effect of the button being 
depressed when clicked.

6. Select the Hit frame in the timeline Draw a rectangle 
bigger than the text in this frame.  Delete the text since this 
state is never seen.  The rectangle defines the hot spot for 
the button.  The bigger it is, the easier the button is to click.

**  In the example portfolio, you’ll see that I added some images to the Over frame and 
Down frame.  You can do the same.  Use File > Import to import a graphic while the 
Over or whichever target frame is selected.  Resize images in Photoshop to the size 
you want them before importing to keep your movie’s file size down.

Next let’s dupe the button we just created and use it as a 
template for the other three buttons we need...

7. In the Library window, select the portfolio button you 
just created.  Then click on the Options menu in the upper 
right corner of the Library window.  Choose  Duplicate.  
Repeat twice to create three new buttons.

8.  Double click each of the new buttons’ names you just created and rename them 
according to the names of the scenes that they will point to: contact, resume and 
statement.

9.  Double click each of the new buttons’ icons and edit the text in their Up, Over and 
Down frames to reflect the name of the scene they point to. Adjust their Hit frame 
rectangle to fit the new text. Now we have all the buttons, let’s place them and add 
actions to make them function.

Adding Actions to the Buttons:

1. Select frame 18 of the buttons layer in the intro scene.  Choose Insert > Keyframe.  
With this new keyframe selected, drag the portfolio button from the Library window 
onto the canvas of the Movie.  Repeat with the other 3 buttons.  Position them where 
you want them.

2. Select the portfolio button.  Open the Actions panel.  With the button selected, 
double click Go to and choose portfolio from the the Scene pop up in the Actions 
panel.  Repeat these steps to point the other buttons to their respective scenes. 

Four states of 
portfolio button

Options in
Library window

Hit state rectangle
before deleting text

Portfolio in Flash continued
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That’s it!  You have the basis of a Flash portfolio.  The last step would be to create 
buttons for the scenes to jump to the next scene or back to the intro.  You can also just 
copy the buttons from the intro scene and paste them in the scenes to allow 
navigation.  Flash 5 also copies the actions when you copy a button to the clipboard, 
so all you have to do is copy the buttons you just made and paste them where you 
need navigation for the viewer.

Next we will modify the portfolio section to accommodate more images.  Skip to 
Publishing on the next page to output your portfolio if you are happy with it as is.

Jumping to Labels:

1. In the portfolio scene, click on the background layer.  
Choose Insert > Layer twice to add two layers.  Name one 
images  and the other labels.

We will have four images in the portfolio section so we need 
to create four labels...  

2. Select frame 1 of the label layer.  Choose Window > 
Panels > Frame.  Type in the label area of the frame 
window image one.

3. Select frame 10 and choose Insert > Keyframe to add a 
keyframe for a new label. Add a label of image two. Repeat 
for frames 20 and 30 naming them image three and image 
four respectively.

4. Add keyframes to frames 1, 10, 20 and 30 of the images layer.  Select frame 1 and 
use File > Import to import an image.  Repeat for frames 10, 20 and 30 importing 
different images.  Next, we need to add stop actions to keep Flash from breezing past 
one image to the next...

5. Add keyframes to frames 10, 20 and 30  of the actions layer.  (frame 1 should 
already have a stop action applied from Page four’s Step number four).  Select frame 
10 of the actions layer.  Open the Actions panel (Window > Actions) and double click 
on stop.  Repeat for frames 20 and 30.

Next we’ll make a button to move from label to label.

6.  Add keyframes to frames 1, 10, 20 and 30  of the buttons layer.  Select frame 1 of 
the button layer and create some text that says “next”.  With that text selected, choose 
Insert > Convert to Symbol.  Name the new symbol next button and give it a 
behavior of button.  Add 3 keyframes and edit the states as we did before at the 
bottom of page four.  Next we’ll add an action to the button to point to the next label...

Labels

Frame Window: Labels
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7. Select the next button on the canvas.  Open the Actions 
panel.  With the button selected, double click Go to and 
choose Frame Label from the Type pop up in the Actions 
panel.  Then choose image two from the Frame pop up in 
the Actions panel.  Next we’ll copy this button and paste it 
on the next keyframe.

8.  Select the next button on the canvas and choose Edit > 
Copy.  Select frame 10 and choose Edit > Paste in Place.   
With the newly pasted button selected, click on the code in 
the right hand area of the Actions Panel, and change the 
frame reference from image two to image three.  Now this 
copy of the button points to the next label. Repeat this step 
to create buttons for frames 20 and 30, making 30 point 
back to image one.  That’s it!  Well done!

Publishing your work:

Keep track of your portfolio.fla file.  This is your project file 
with the layers, scenes, etc. from which you publish a 
number of files.  Without it you cannot edit your movie.  After 
every revision, publish your files using File > Publish.

Whenever you choose Control Test > Movie you publish a 
new .swf movie.  If you preview in a browser, File > Publish 
Preview > HTML (F12), you will also publish an html page 
to view the .swf movie.

To publish a stand alone Mac projector and PC projector, 
choose File > Publish Settings.  Check Macintosh and 
Windows Projector.  Click on the Publish button in this 
window or click OK and choose File > Publish to output the 
files.  They will be output to the same place that you saved 
your Flash project file.

Projectors are a copy of your movie melded with the Flash 
player into a single file that is a stand alone application.  
They do not require any additional software to view them. 
You can copy them onto a Zip disk, compress it and email 
it, burn it on a CD or place it on a PC formatted floppy disk 
and hand it out.

To add your movie to your web site, copy the web page and 
web movie to your iDisk or web server.  Be sure to keep 
them together so as not to break the link between the page 
and the movie.  Keep up the great work!

Actions Panel pointing to Labels

Code in right side of Actions
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